debian/Linux yarn问题

发布于 2021-03-20  50 次阅读


在Debian或Ubuntu Linux上,你可以通过我们的Debian软件包库安装Yarn。你首先需要配置存储库:

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list

在Ubuntu 16.04或更低版本以及Debian稳定版上,您还需要配置NodeSource存储库,以获得足够新版本的Node.js。
然后你可以简单地:

sudo apt update && sudo apt install yarn

注意:Ubuntu 17.04默认安装了cmdtest。如果你在安装yarn时出现错误,你可能需要先运行sudo apt删除cmdtest。更多信息请参考这个。
如果使用nvm,你可以这样做来避免安装节点:

sudo apt update && sudo apt install --no-install-recommends yarn

注意:由于在一些发行版中使用nodejs而不是node name, yarn可能会抱怨node没有被安装。解决这个问题的方法是在.bashrc文件中添加一个别名,如下所示:alias node=nodejs。这将把yarn指向您决定使用的任何版本的node。
Path Setup
如果未在 PATH 环境变量中找到 yarn,请按照以下步骤添加 yarn 到 PATH 环境变量中,使其可以随处运行。

注意:您的配置文件可能是 .profile、.bash_profile、.bashrc、.zshrc 等。

将此项加入您的配置文件: export PATH="$PATH:/opt/yarn-[version]/bin" (路径可能根据您安装 Yarn 的位置而有差异)
在终端中,执行登录并登出以使更改生效
为了可以全局访问 Yarn 的可执行文件,你需要在控制台(或命令行)中设置 PATH 环境变量。若要执行此操作,请添加 export PATH="$PATH:yarn global bin" 到你的配置文件中,或者,如果你使用的是 Fish shell,直接执行此命令 set -U fish_user_paths (yarn global bin) $fish_user_paths 即可。

通过如下命令测试 Yarn 是否安装成功:

yarn --version

擦肩而过的概率